Resident Verify Reporting
Incident Report for Entrata
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 09:53 MDT
Update
We are continuing to investigate this issue.
Posted Apr 17, 2024 - 09:38 MDT
Investigating
Entrata engineering is aware of an issue impacting results of screening for applicants related to resident verify reporting. We are actively working on this issue.
Posted Apr 17, 2024 - 09:36 MDT
This incident affected: Entrata Standard (Entrata Standard Application) and Entrata Rapid (Entrata Rapid Application).